The MIG Console is now operating healthily. If customers continue to experience any issues, please reach out to us at support@movementinfrastructure.org
Posted Jun 12, 2025 - 22:20 UTC
Update
We are seeing some recovery with apps loading in the MIG Console, but continue to monitor for any other affected areas. For the latest, refer to https://status.cloud.google.com.
Posted Jun 12, 2025 - 19:28 UTC
Monitoring
The MIG Console is experiencing an outage as a result of Google Cloud and CloudFlare outages that are downstream. We are monitoring and will update this incident once it has been resolved.
Posted Jun 12, 2025 - 19:16 UTC
This incident affected: MIG Console and Dataset Exchange API.